B15 Sentra Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
980 Posts
Discussion Starter #1
Well the time has come to ditch my 3 amp system. One is down and I am sick of dealing with 3 amps and they take up too much space.

I am running 3-way up front and 1 sub in the rear. I am using an AudioControl DQX for EQ and crossover. I have 7" Vifa PL as Mid-Bass, Iridium3's as mids and MB PSD tweets.

I would love a 7 channel one for all, but that is seeming impossible so I am going to go with a 6 and a mono.
I can get a DEI 700/6 for $210. The 700/6 does 50wx4 at 14.4v and 75x2 at 14.4v .
I can also go with JL e6450 which is 40/6 at 12.2v (heard it is about 60x6 at 14.4) but it is $400.
Anyone know anything about the DEI amps?
 

·
Registered
Joined
·
5,293 Posts
whoa where the hell did you come from?

nice setup, wish I knew more about 6 channel amps so I could help you :(
 

·
Registered
Joined
·
6,819 Posts
i understand wanting to simplifiy. as i neared the end of my audio journey i simplfied more and more.. till i had nothing..

i dont think you'd hear a difference in sound quality if you got the JL. But it might look a bit cooler. you prob dont even want to go here, but theres a TRU 6 channel amp. But I'm sure it runs about $1000 at least.

Seems like you already have good equipment. So I know why they call you placenta.. changing your system even tho you have a nice setup already..
 

·
Registered
Joined
·
966 Posts
there are A/D/S multi channel plate amps all the time on ebay, don't know if that helps you or not........
 

·
Registered
Joined
·
1,794 Posts
i have a dei amp in my sti, but its a 600.1 mono amp.. all i can say is its a great piece for the price i had it powering 2 w3's in the spec and it worked really well. although i can;t say much for the other ones they make since i haven;t tried them i would definitly be willing to
 

·
Registered
Joined
·
980 Posts
Discussion Starter #6
placenta said:
Seems like you already have good equipment. So I know why they call you placenta.. changing your system even tho you have a nice setup already..
Well the XTANT kinda crapped out on me. It was my fault, screwed it to MDF and one of the screws fell out, and since they are under the case you can figure out the rest:) I fixed it once, but I guess I missed something and it went out again.

The amp I have powering the tweets, only comes on when it feels like it.
So it is about time to switch.
 
1 - 6 of 6 Posts
Top