B15 Sentra Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
Hey guys, I just installed my new radiator which I just found out is sold for 1.8 Sentras only. It fit mine perfectly, but there is a slight problem. One of the fans is not working. I was trying to figure out why but couldn't, so i thought maybe you guys would know something?!?! :)
 

·
knotrly
Joined
·
1,295 Posts
You probably hooked it up incorrectly. I am going to venture a guess that we would need more information then just your fan isnt working to figure out why.
 

·
Registered
Joined
·
59 Posts
Discussion Starter #3
Well the radiator also isn't for a spec-v engine its for a 1.8s sentra engine, but it first perfectly fine. So I have no idea why the fan wouldn't be working, but we checked and it's hooked up correctly. Thanks Turco
 

·
knotrly
Joined
·
1,295 Posts
Well the radiator has nothing to do with the fans other then the fans sit on them. So the the fan not turning onprobably is due to another issue. I dont know if there is a difference between the two but I wouldnt suggest using a 1.8l radiator on a 2.5l car. It should all fit since the radiator supports are the same on all the cars.
 

·
"Registered Abuser"
Joined
·
1,272 Posts
turco said:
I dont know if there is a difference between the two but I wouldnt suggest using a 1.8l radiator on a 2.5l car. It should all fit since the radiator supports are the same on all the cars.
i agree if it was fine to use the same radiator for the two motors dont you think of all people nissan would have done that from the factory to save a ton of production cost money. Theres a reason why the 2.5 has a differant one be careful
 

·
Registered
Joined
·
563 Posts
Does anyone even know if they are different?
 

·
Registered
Joined
·
1,159 Posts
Saint-Knight said:
wait, it's all bull****, listen the second fan suppose to work when A/C is on. Try then and let me know
Saint is correct.
 

·
Registered
Joined
·
2 Posts
I believe if you put on your A/C and turn it to speed 4, the fan should come on. Unfortunately I have a 2.5 non-spec v ser and mine is not coming on either. My temperature runs fine but I believe it should be running, especially while turning on max a/c. I have to get it looked at if not the relay/fuse...✌
 

·
Registered
Joined
·
12 Posts
Here's another thread for cooling fan issue:

I was helping a buddy installing the suspension and brake kit from 4Wheelonline onto his truck when his uncle arrived on 2006 B15. The same issue and it was due to blown fuse.
 

·
Registered
Joined
·
2 Posts
What fuse # is it and how many amps. I heard on most B15s that only one fan works unless the car is about to overheat and the temp is too high and that's when the 2nd fan will turn on...
 

·
Registered
Joined
·
12 Posts
What fuse # is it and how many amps. I heard on most B15s that only one fan works unless the car is about to overheat and the temp is too high and that's when the 2nd fan will turn on...
I'll come over to buddy's friend next week to finish installing the headache rack and vision truck wheels onto his SIlverado. I'll see if I can ask his uncle about the fuse.
 
1 - 12 of 12 Posts
Top