B15 Sentra Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
I have a 2000 sentra GXE and I am planning on changing the filter. I found a filter made by APC and it fits. The only thing is that I need an O2 sensor adapter. Cuz without it, it makes a weird sucking noise. Does anyone know where I can get an O2 sensor adapter? Also, is there even a pipe made for the intake yet? If so, where I can I get one of those? (I am not looking for any cold air intake systems though).

After trying to put on the filter and findig out that it needs the O2 sensor, I put everything back together, just like it was supposed to be, but now when I turn on the car, the "Engine Service Soon" (something like that) indicator light stays on. What does that mean? Did I mess up or something?
 

·
Registered
Joined
·
3,122 Posts
basically you tripped the O2 sensors and i think you could dissconnect the + on the battery and it'll reset the computer.....someone correct me if i'm wrong

and no one has just the intake pipe but you can buy just a pipe from www.speedandstyle.com and build one yourself....

------------------

CAR:
Black 2k SE Performance/package

MODS:
17x7 Konig-Caffeine's ,Stillen front spoiler and pop-cone intake,Aluminum dash kit,Remote starter,35% Tint,APC Super white headlights and fogs and front and rear turn signals,Ventshade-ventvisors,Custom Front Grille,Stromung cat-back(in the mail)......
CLICK HERE FOR MY CAR PICS http://albums.photopoint.com/j/AlbumIndex?u=1428062&a=10696175
 

·
Registered
Joined
·
3,122 Posts
thanks 2000se you dissconnect the negative terminal and let it reset itself.....

------------------

CAR:
Black 2k SE Performance/package

MODS:
17x7 Konig-Caffeine's ,Stillen front spoiler and pop-cone intake,Aluminum dash kit,Remote starter,35% Tint,APC Super white headlights and fogs and front and rear turn signals,Ventshade-ventvisors,Custom Front Grille,Stromung cat-back(in the mail)......
CLICK HERE FOR MY CAR PICS http://albums.photopoint.com/j/AlbumIndex?u=1428062&a=10696175
 
M

·
Guest
Joined
·
0 Posts
I think I need to pull *MY* negative terminal, and let myself reset. It's been one of those days. hehe.

------------------
2001 SE
P/P, 5 spd.
Cloud White

MODS:
------
- Stromung Stainless Cat-back. (On The Way!!)
- Hotshot CAI (At The Coaters.)
 

·
Registered
Joined
·
60 Posts
Discussion Starter #6
Thanks guys. I didn't think it would be that simple. I was getting sorta worried because it wouldn't go away. It was getting pretting annoying seeing that light on while I'm driving.
 

·
Registered
Joined
·
60 Posts
Discussion Starter #7
how exactly are you supposed to let it reset itself? becuase I disconnected the negative terminal and then put it back on and the light didn't go away. Do I let it sit there for a little while then connect it again, leave it off over night, or what? I don't know. And I don't want to take it to the dealership.

Also, does anyone know where I can get an O2 sensor adapter at?

Please help me.

[This message has been edited by CyBorG (edited February 07, 2001).]

[This message has been edited by CyBorG (edited February 08, 2001).]
 

·
Registered
Joined
·
13 Posts
Yes, you do want to leave it off overnight. That will allow it to reset and that damn light will finally turn off.
 

·
Registered
Joined
·
259 Posts
yes, overnight. also remember that if it does not go away immediately, that should be okay. the ECU is a learning ECU. If it does not go away immediately, give it 150 miles or so.

------------------
MY PAGE
 

·
Registered
Joined
·
60 Posts
Discussion Starter #11
Hey sentrastyling, did you add anything else to your filter to connect it to the pipe becuase when I tried, it made a funny noise, I think I may be missing something huh? How exactly did you do it. What's that thing with the stillen sticker on it? is that what I need?
 

·
Registered
Joined
·
3,122 Posts
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by CyBorG:
Hey sentrastyling, did you add anything else to your filter to connect it to the pipe becuase when I tried, it made a funny noise, I think I may be missing something huh? How exactly did you do it. What's that thing with the stillen sticker on it? is that what I need? <HR></BLOCKQUOTE>

yes that is needed that's where your sensor plugs into,,,one of them.....but if you look at the end of the filter you'll see a red cap well i just put the pop-cone in my car and didn't attach the other sensor there yet....

------------------

CAR:
Black 2k SE Performance/package

MODS:
17x7 Konig-Caffeine's ,Stillen front spoiler and pop-cone intake,Aluminum dash kit,Remote starter,35% Tint,APC Super white headlights and fogs and front and rear turn signals,Ventshade-ventvisors,Custom Front Grille,Stromung cat-back(in the mail)......

*CLICK HERE FOR MY CAR PICS*
 

·
Registered
Joined
·
1,267 Posts
should have went with the JWT POP... its carb legal.... but if you want some bang for your buck...... Cold Air is the only way to go!!!

------------------
2000 Nissan Sentra SE - HP RacingMotorsport Coilovers - Razo Carbonfiber Pedals - Razo titanium shift knob - Razo Shift Light - Nology Hotwires - Hotshot header and CAI on the way!!!
 
1 - 13 of 13 Posts
Top