B15 Sentra Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Just noticed today after getting an alarm installed on my 00' Gxe that the horn isn't working. It's definately not the blown fuses, and it has worked before. YES, i searched and came up with that it's common with B15 xe/gxe's and to fix it would be to take it to the stealership to get it fixed, but i'm obviously out of warranty.
Anyone who's encountered this problem before know of the wire to fix/rewire with a new one? Please and thanks!
 

·
Registered
Joined
·
2,104 Posts
did you install it yourself? no? go take it to the place that installed it and make them fix it for free.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #3
nah didn't install the alarm myself but it wasn't working before the alarm was installed either lol. I tried to honk in the parking lot of the alarm/stereo shop and thats where i noticed it didn't work.
I noticed it's a common problem because of the rubbing between the radiator and some lower mounts, and it is a VERY thin wire;

anyone else know of how to fix/upgrade the wiring?
 

·
Registered
Joined
·
3,416 Posts
Mine failed, but it squawked for awhile before it died alltogether.

Open your hood, look behind the grill.....remove the horn.

test the horn against a 12 volt source. If it fails, go to a parts store and buy an aftermarket horn and wire that **** up. If it works, you've got a wiring or fuse problem.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #6
Yeah went outside this morning, removed the horn and it works, it's definately the wiring. Anyone know what wire(s) to tap into or run from fuse/relay box or both? (Man, theres a MESS of wires everywhere... need the horn! Long Beach, CA.... suburbs.. ahh!)
 

·
Registered
Joined
·
3,416 Posts
guess that middle finger is going to get a good workout over the next few days.......

you aught to buy a foghorn to use untill you've got new wiring run.

You may want to check where the horn wire goes around the radiatior. I've heard some people had problems because the wire got chewed up or broken there.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #8
On a side note, which is the wire in the relay box that leads down to the horn?
I'll probably just end up splicing into that wire and running a new wire down to the horn, should work if the factory wire got mashed between the cross member and radiator.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #9
I just tried to rewire the wire coming from the relay box to horn, and it still doesnt honk. I tested the horn on a 12v source and thats fine, could it possibly be the relay "blown" ? when i press the steering wheel, i don't hear the relay clicking, is it spose to?
 

·
J-E-T-S JETS JETS JETS
Joined
·
182 Posts
It should be the wire down under the radiator. It gets pinched between the radiator and the frame. It is with a whole mess of wires. I brought mine to the dealer and they fixed it for $45.
 

·
Registered
Joined
·
2,093 Posts
you know what ive always wanted to do?

air horn from one of my dad's mack trucks... complete with pull handle on the roof of the car... (my dad's president of dispatch at a trucking company)

one day...
 
1 - 14 of 14 Posts
Top