B15 Sentra Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter · #1 · (Edited)
I installed a Revotec air intake for my Sentra gxe and starting up the car, it was choking, sputtered and had a rough idle. I put the two hoses on the small intake piece, clamped on the longer intake then air filter in place. Anyone know what's wrong? I couldn't even drive it home from my friend's house, so I had to put the stock filter back on. This is what I bought. Intake
 

·
King of OT
Joined
·
5,210 Posts
Is your MAF still in the setup...
 

·
Bow to your SE GOD
Joined
·
4,702 Posts
pugnex said:
Is your MAF still in the setup...
What he means is, if you had to take your MAF off and install inline with this CAI, make sure the direction of the "Flow" arrows are towards the engine, not the air filter.
Revotek, huh? :confused:
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #5 ·
When I installed it, I took everything off. I had only the two new intake pieces and the accessories on.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #6 ·
I don't see any flow arrows, there are no labels

audio1der said:
What he means is, if you had to take your MAF off and install inline with this CAI, make sure the direction of the "Flow" arrows are towards the engine, not the air filter.
Revotek, huh? :confused:
 

·
Registered
Joined
·
842 Posts
Did you take the MAF out of the stock intake and install it in the CAI?
 

·
Registered
Joined
·
6,144 Posts
yah if you're mass air flow is in the wrong place, or wrong direction, or just not in, holy god is it going to run bad, if at all.
 

·
★★★★★
Joined
·
8,477 Posts
uhhhh yeah, you need a MAF :D
like pditty said i'd be surprised if your car is running at all
 

·
King of OT
Joined
·
5,210 Posts
I believe I asked about the MAF first.....
 

·
King of OT
Joined
·
5,210 Posts
The setup will have a coupler attached to the throttle body which connects to the smaller pipe, then there is another coupler which connects to the maf which is a black plastic tube with a plug in it, there is an arrow on the maf housing which represents which way the air is supposed to flow, from there you have another coupler and the downpipe intake pipe which attaches to the filter.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #13 ·
I connected the CAI, maf and arrow plug, but its still rough idle and choking when I give it gas. I even tried to connect the sensors from the stock air box, with the CAI, but still chokes. Only when I connect the stock intake, maf with stock airbox, connect the sensors, then it runs smoothly. I tried different combos, short ram intake, plug all tubes, maybe CAI's don't work with gxe. I'm going to return it.
 

·
Registered
Joined
·
897 Posts
bass4040 said:
I connected the CAI, maf and arrow plug, but its still rough idle and choking when I give it gas. I even tried to connect the sensors from the stock air box, with the CAI, but still chokes. Only when I connect the stock intake, maf with stock airbox, connect the sensors, then it runs smoothly. I tried different combos, short ram intake, plug all tubes, maybe CAI's don't work with gxe. I'm going to return it.
is there an insert or hole for the temp. sensor in the intake? I believe its the termperature sensor...
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #15 ·
there's a small hole in the long intake piece. How do I shove the larger temperature sensor in that?
 

·
Registered
Joined
·
897 Posts
bass4040 said:
there's a small hole in the long intake piece. How do I shove the larger temperature sensor in that?
If theres no hole in the intake for the temp. sensor.. then your going to have to make a hole yourself... thats what happens when you buy a generic brand for the damn GXE ;)
I personally bought the Place Racing CAI, and it had a hole perfectly fitted for the temp. sensor... but hey, thats what happens when you spend almost $200...
 
1 - 17 of 17 Posts
Top