B15 Sentra Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi everyone,

I have a 2009 Sentra FE+ with 114k miles on it. To my knowledge, the fluid has never been changed. I'm the second owner and I bought it from Enterprise in 2011 with about 50 or 60k miles.

Two weeks ago, less than 1k miles, I did a drain and fill of 4.25ish quarts of Castrol CVT NS-2 compatible fluid. I was having some sluggishness in the car, and I wasn't sure if it was the plugs (which had also never been changed) or perhaps tranny. So, I replaced tranny fluid with this. https://www.amazon.com/Castrol-06811-6PK-Transmax-Black-Transmission/dp/B00T96Q956/ref=cm_cr_arp_d_product_top?ie=UTF8

It seemed to really pep up the car, but now it feels sluggish again and I'm even noticing it feels heavier, revs up before it engages in power, etc, which just started yesterday.

Did I make a HUGE mistake by using non-Nissan NS-2 fluid? Or can I cross my fingers and hope the plugs will effect something too? This fluid is red which worries me, although I do know it's for CVT and NS-2 compatible...

If I did make a huge mistake, should I drain and replace with the real deal immediately?

Thanks!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
I should add that otherwise the transmission seems fine. It shifts well when going. It's really the half-second hesitation between gassing it/RPMs going up and the car actually starting to go. There are a few occasional weird feelings, but the tach looks normal.

I did have an odd moment where I shifted it into drive when leaving lows and it hesitated and bogged twice before getting going.
 

·
Registered
Joined
·
3 Posts
I'm late but also interrested by an expert recommendation. Just bought the car and not sure what kind of shifting is normal in this weirdo tranny. Also interrested in fluid replacement. 175k KMs and probably never been changed. Engine oil was so black that I'm sure he never touched trans fluid.
 
1 - 4 of 4 Posts
Top