B15 Sentra Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1
I started searching but havent found anyones symptoms to be similiar to mine. About two days ago I was driving like usual and when leaving Home Depot the car just wouldn't start. everything pionted to the battery although there were no indications of it going bad before. So i bought the Optima red and installed it. Being bigger than the stock it was a tight fit and I guess I will need to extend my wires. But the next day when starting the car it would just shut off, and when I cranked it again it started but dipped to the piont of stalling and would catch real quick and continue to idle. Everything else is fine it runs with no problems when just sitting there only on ignition, there are no lights on or anything. I noticed the battery tore the foam on my bypass valve could that be it. Id like to get an idea before taking it in losing my car for a couple days.
 

·
Lower than u will ever be
Joined
·
622 Posts
I've been having that same problem for almost 2 years, couldn't figure out what it is, and just found out this morning that the Idle Air Control Valve is bad. I have no idea what that is or where it is but that's what it is causing it. Mine also over the last few months has started running really rich and pouring out black smoke from the exhaust that smells so strong of gas you could probably light it on fire. The part is $279 from auto zone and was well over $400 from the stealership, that's why I haven't replaced mine yet. I never got a SES light from it either but when I got a SES light cause my gas cap went bad it threw a code for it (P0505) and I had it checked out and that's what it is.
 
1 - 3 of 3 Posts
Top