B15 Sentra Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Okay I bought this car ",it has been sitting for 10 years. Long story short lady passed away left sitting I ended up with it. I put a hot battery on it and absolutely nothing in the car works. Cluster windows locks fuel pump hazards radio brake lights nothing. What does work blower motor. Engine starts with gas in the intake. Anyone ever had a issue like this. I know I'm going to start checking grounds but didnt know if there would be a main fuse of some sort on these cars that powered everything mentioned. Also the door dinger works
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Sitting for 10 years? oof.. I'd check to see if rodents chewed through any harness wires. There should also be a main fuse/relay box under the hood, to the left of the battery.
I found the mail fuse was blown I appreciate it
 

·
Registered
Joined
·
151 Posts
its been sitting for 10 years? Id say maybe the gas has corroded within. internals with sludge from the oil. probably seized engine. the 2000 is a really old car, far and few are still left around. My bro has a 2001, but he has a rebuilt engine. and it still runs lol. However the sr20de is a really reliable engine.
Check the fuel pump which should be located underneath the back seat, and it, discard all old gas. check spark plugs, coils. You can also email 2JR racing or check their website.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I got it going main fuse was blown replaced fuel filter battery and serpentine belt runs like a new on has 95k miles
 
1 - 5 of 5 Posts
Top