Auto Transmission Sift Lock Not unlocking - B15sentra.net - Nissan Sentra Forum
B15sentra.net - Nissan Sentra Forum
 
Go Back   B15sentra.net - Nissan Sentra Forum > 2000-2006 B15 Nissan Sentra > Technical Discussion

B15Sentra.net is the premier Nissan Sentra Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Rate Thread
Old 04-19-2006, 09:40 AM   #1
jcrow
Registered User
 
Join Date: Apr 2005
Location: San Diego, CA
Auto Transmission Shift Lock Not Unlocking

03 Auto GXE 58,500 Miles (yes this post is a long one, sorry)

The problem:
Start car and press the brake in then attempt to shift the auto transmission into gear. The shifter doesn’t move!


Has anybody had this problem before? I have searched and didn’t find anything on this topic. So that is mainly why I am posting this.

I know how to manually unlock it so I can still get around. (For those who don’t know how to do it look in the Owners Manuel) The break lights work so I know the break switch is good. So I pulled out the fsm and start looking around for the A/T shift lock system. I found it and start going threw the troubleshooting steeps. (page AT-251)

Step 1
Check key interlock cable for damage.
-ok not damage

Step 2
Check selector lever position for damage
- ok not damage

Step 3
Check power source at stop light switch
- ok the break lights light up so I am not going to craw under the dash

Step 4
Check input signal @ the “A/T Device” (shifter)
- should be 12vdc when the brake pedal is pressed. wait…. I am getting no power…. But the stop light switch is working………d@m another sentra with wiring problems.

(Going threw the procedures in this step it says you should get 0vdc when you have the pedal depressed and 12 vdc when released BUT looking at the schematics in the fsm you should get 12vdc when you depress the pedal and 0 vdc when released) But in both cases I am not getting any volts dc. I have not checked the resistance on the cable yet because I believe I have to remove the break lights to get a good reading.

That is as far as I am going to go. Why? Because I have extended warranty (not threw Nissan) so it will cover the electrical system and I want to get what I paid for. I have an appointment on Friday @ Nissan to look at this problem and want to see how long it takes them to find it out. It took me about 15 minutes from pulling the book out and reading it to inserting the last trim piece back into place. For me this was an easy problem to find because I am an electrician in the navy. So if I was going to fix it I would run a new wire from the stop switch to the terminal 7 on the “A/T device” If someone down the road has this problem I hope this helps. I’ll post back when the car gets fixed.

Last edited by jcrow; 04-19-2006 at 04:35 PM. Reason: I can't spell!
jcrow is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-19-2006, 01:25 PM   #2
tony22r
'02 QG18DE
 
Join Date: Oct 2004
Location: CA
Quote:
Originally Posted by jcrow
The sifter doesn’t move! Has anybody had this problem before?
this happened on my sister-in-law's '95 Chev Cavalier.. iirc brake hit a switch, activating solenoid at console shifter.
I opened up console and unplugged solenoid.. maybe i removed it.. maybe i cut the locking mechanism, don remember. Fixed.

Doesn't sound like you tested the solenoid itself? when energized it should move.
tony22r is offline   Reply With Quote
Old 07-03-2006, 12:23 AM   #3
GXE2001
Registered User
 
Join Date: Jul 2006
Shift lock not unlocking

Hi,

I have the same problem. Did you find the reason?

Thanks.
GXE2001 is offline   Reply With Quote
Old 07-03-2006, 10:50 AM   #4
jcrow
Registered User
 
Join Date: Apr 2005
Location: San Diego, CA
I thought I posted that it got fixed. Well sort of. The day I had the appointment at the dealer the car fix it self. I know that it was the wring because my speakers were loosing signal from the headunit. I just blame it on my wife for hitting pot holes. @ 9,000 she already broke the front right strut. Warranty coved it.

So, you have the same problem and you are not under any warranty, right? Do you have a multi-meter? If you do I can help you track down the problem. The first thing to check is to make sure you do have brake lights in the back.
__________________
03 GXE VIBRATE BLUE
k&N Drop In Filter / SS brake lines.
RIP DEC 2008

08 Versa SL
61,000
Sold

12 Rogue AWD
jcrow is offline   Reply With Quote
Old 07-03-2006, 01:48 PM   #5
GXE2001
Registered User
 
Join Date: Jul 2006
shift lock

Thanks for the quick reply. I bought the car used and has already more than 100k miles on it. I do not think it has any warranty. I did not do the tests you mentioned. I can borrow a multimeter.

I opened the console. I think there is a problem with the solenoid.

I will do the tests and let you know.

Thank you again.
GXE2001 is offline   Reply With Quote
Old 03-17-2009, 10:41 PM   #6
Jeremy_ESQ
Registered User
 
Join Date: Nov 2002
Location: Toronto
Okay, I have this problem too. Interestingly, it seems like if I press and hold the brake pedal down, eventually the interlock will engage and allow me to shift out of PARK. Does this mean I have a bad solenoid or perhaps is it time to replace my battery? I am still running on my original battery and my car is a 2002.
Jeremy_ESQ is offline   Reply With Quote
Old 03-17-2009, 11:38 PM   #7
chiquae07
Informed Lurker
 
Join Date: Oct 2006
Location: South FLa
Send a message via AIM to chiquae07
Quote:
Originally Posted by Jeremy_ESQ
Okay, I have this problem too. Interestingly, it seems like if I press and hold the brake pedal down, eventually the interlock will engage and allow me to shift out of PARK. Does this mean I have a bad solenoid or perhaps is it time to replace my battery? I am still running on my original battery and my car is a 2002.
did you possibily change the bulb in it to illuminate up the letters? if so, you might have moved the linkage just enough to make it be a p.i.t.a.. thats what i did, and i ended up making it so i can shift it out of park when the keys arent in it or the brake is pushed down.
__________________
Suck up a kitten
Eat a butterfly
Replace with WRX

2001 Granite Sentra Se wit PP

Quote:
Originally Posted by txspeccer View Post
Slow car races are exciting. For those 19 seconds until you hit 80 mph, nothing else matters.
chiquae07 is offline   Reply With Quote
Old 03-18-2009, 05:52 AM   #8
Jeremy_ESQ
Registered User
 
Join Date: Nov 2002
Location: Toronto
No, I have not changed the bulb (it died awhile ago but I figured I could live without it). Having never opened the shift console before, would it be possible that the linkage may have gotten displaced over time from the car going over its fair share of bumps & potholes?

Like I said, the interlock still disengages, but is very slow to do so. Almost 90% of the time, it does not disengage within a second of the brake pedal being pressed (like it is supposed to). I normally have to press and hold the pedal for maybe 5-10 seconds, then I will be able to successfully press the shift button on the lever.
Jeremy_ESQ is offline   Reply With Quote
Old 04-23-2013, 12:49 PM   #9
tachi1247
Registered User
 
Join Date: Jan 2012
Hate to revive a thread this old, but does anyone know the part number for the the shift interlock solenoid? I'm pretty sure that is what is wrong with my wife's car as of this morning, and all my searches indicate this is an inexpensive (~$40) part, but no one lists a part number and I can't find anything on autozone/advance/etc websites.
tachi1247 is offline   Reply With Quote
Old 04-23-2013, 02:05 PM   #10
jcrow
Registered User
 
Join Date: Apr 2005
Location: San Diego, CA
Quote:
Originally Posted by tachi1247 View Post
Hate to revive a thread this old, but does anyone know the part number for the the shift interlock solenoid? I'm pretty sure that is what is wrong with my wife's car as of this morning, and all my searches indicate this is an inexpensive (~$40) part, but no one lists a part number and I can't find anything on autozone/advance/etc websites.
Your best bet is a junkyard.
__________________
03 GXE VIBRATE BLUE
k&N Drop In Filter / SS brake lines.
RIP DEC 2008

08 Versa SL
61,000
Sold

12 Rogue AWD
jcrow is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:31 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.